Back to overview
Downtime

Dashboard is unavailable

Jul 01 at 09:56am IST
Affected services
Dashboard

Resolved
Jul 01 at 12:07pm IST

We are pleased to inform you that the recent issue affecting our Dashboard service has been successfully resolved, and the service is now fully operational. We apologize for any inconvenience this may have caused and appreciate your patience during the downtime.

Created
Jul 01 at 09:56am IST

Due to issues with the timesheet inbox, we are working on resolving the issue soon. Your patience is appreciated.