We are currently experiencing a service degradation affecting Storage Accounts in the Central India region.
Resolved
Feb 18, 2026 at 04:08am UTC
All resources are restored
Affected services
Created
Feb 17, 2026 at 07:41am UTC
We are currently experiencing a service degradation impacting Azure Storage Accounts in the Central India region, which may cause increased latency, intermittent timeouts, and occasional HTTP 500 errors. This issue is due to an ongoing Azure platform incident, and no ETA for resolution has been provided yet. There is no evidence of data loss, and we are actively monitoring the situation and will share updates as they become available.
Affected services